Salut,

Le 12/11/2016 à 20:48, Amaury Froment a écrit :
> Bonjour à tous,
> j'aimerais savoir si l'un de vous a testé Galette V0.8.3
> (http://download.tuxfamily.org/galette/galette-0.8.3.tar.bz2) avec une
> configuration serveur:
> Wampserver 3.0.6 32 bit x86 – Apache 2.4.23 – PHP 5.6.25 – MySQL
> 5.7.14 – PhpMyAdmin 4.6.4
> 
> De mon côté, l'installation se passe conformément à la doc mais
> lorsque je veux créer un adhérent j'ai l'erreur suivante:
> "Fatal error: Uncaught exception 'PDOException' with message
> 'SQLSTATE[HY000]: General error: 1366 Incorrect integer value: 'false'
> for column 'required' at row 1' in
> C:\wamp\www\galette-0.8.3\galette\includes\Zend-2.3.7\Zend\Db\Adapter\Driver\Pdo\Statement.php
> on line 244" (voir pièce jointe).

Au vu de l'erreur, ce n'est pas spécifique à l'environnement - à priori.

Je me demande cependant si tu as bien les fichiers de la 0.8.3.

Le fichier de log fourni fait référence à plusieurs lignes de
FieldsConfig.php :
3       0.1089  4279600 Galette\Entity\FieldsConfig->_checkUpdate( )
...\FieldsConfig.php:151


==>
https://github.com/galette/galette/blob/0.8.3/galette/lib/Galette/Entity/FieldsConfig.php#L151

4       0.1130  4304952 Galette\Entity\FieldsConfig->_insert( )
...\FieldsConfig.php:313


==>
https://github.com/galette/galette/blob/0.8.3/galette/lib/Galette/Entity/FieldsConfig.php#L313

5       0.1141  4365592 Zend\Db\Adapter\Driver\Pdo\Statement->execute( )
...\FieldsConfig.php:829


==>
https://github.com/galette/galette/blob/0.8.3/galette/lib/Galette/Entity/FieldsConfig.php#L829

Bref, pour moi, il y a un truc qui cloche là.

As-tu tenté de modifier un code quelconque, ou s'agit-il d'une 0.8.3
verbatim ?

++
-- 
Johan

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Galette-devel mailing list
Galette-devel@gna.org
https://mail.gna.org/listinfo/galette-devel

Répondre à