Bonjour,
une [0]faille dans adodb vient d'�tre publi�e. Cette derni�re affecte
toutes les version inf�rieurs � la 4.71 (et donc celle que nous
utilisons pour l'instant dans toutes les versions, cvs y compris) si
utilis� avec PostgreSQL.

Si vous utilisez galette avec PostgreSQL, il vous *faut* mettre � jour
adodb, pour se faire :
#t�l�charger la version 4.71 d'adodb � l'adresse suivante :
http://sourceforge.net/project/showfiles.php?group_id=42718&package_id=34890&release_id=387862

#prendre soit adodb471-1.tgz (de pr�f�rence si vous etes sous Linux) soit
adodb471-1.zip

#se rendre dans le repertoire de galette
% cd /var/www/.../galette/

#d�placer ou renommer le r�pertoire adodb
% mv adodb adodb-old

#d�compacter l'archive adodb471-1 ici
% tar xvfz adodb471-1.tgz 

Le d�compactage cr�e un nouveau r�pertoire adodb normalement, il ne
reste plus qu'� v�rifier que tout fonctionne correctement.

Si vous n'utilisez pas PostgreSQL cette mise � jour n'est pas
obligatoire, mais corrige quand m?me un certain nombre de bugs et ne
devrait en rien casser des choses dans galette, donc dans le doute
upgradez.

L'archive de la 0.62a est en train d'�tre reconstruite par Lo�s et
remplacera l'ancienne. Pour la version cvs, nous y r�flachissons depuis
quelque temps car justement cvs pose des probl�mes (impossible d'effacer
"r�ellement" un r�pertoire), une migration vers svn pourrait r�soudre le
probl�me.


Si vous rencontrez des probl�mes, et/ou (surtout ;) ) si vous trouvez des
solutions n'h�sitez pas � poster sur galette-discussion ca peut servir �
tout le monde.

Bonne journ�e.

[0] : http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0410
-- 
"Ce ne sont pas ceux qui courent le plus vite
qui sont les plus presses."
[ Coluche ]

Répondre à