Bonjour,

Le 20/10/2009 14:26, roland.te...@gmail.com a écrit :
> Le mardi 20 octobre 2009 à 14:02:33, rezo...@... a écrit :
>> La création d'un adhérent marche bien, mais quand je veux créer une  
>> contribution, je vais jusqu'à la fin mais il ne créait aucun  
>> enregistrement dans la base de données.
>>     
> Dans la fiche de l'adhérent ou peut-être dans la contribution elle-même,
> n'auriez-vous pas inséré un caractère spécial dans un champ particulier (&
> pour le nommer ?) ?
>   

Non, rien à voir ; l'utilisation de ce type de caractère pose problème à
l'affichage ; pas à l'enregistrement dans la base.

Concernant l'erreur renvoyée après activation du mode debug de adodb ;
c'est simplement du au fait qu'il ne soit pas capable de fournir du XML
valide... (j'ai du mal à saisir l'intérêt des espaces insécables tels
qu'ils sont utilisés dans le cas présent, mais bon...).

Pour pouvoir tracer le souci à l'enregistrement des cotisations, en
utilisant ce mode débug ; il faut d'abord afficher le formulaire avec le
debug à false ; puis le passer à true avant d'envoyer.
Bien entendu, la même erreur sera affichée par le navigateur ; mais en
regardant le code source de la page, les infos seront bel et bien présentes.

Je viens de tester l'enregistrement de cotisations sur la démo ainsi que
sur une installation locale ; je ne suis pas parvenu à reproduire le
problème :/

En espérant que les infos de déboguage de adodb soient parlantes ; car
je n'ai pas la moindre idée concernant le souci :-(

Bonne soirée,
Johan

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Galette-discussion mailing list
Galette-discussion@gna.org
https://mail.gna.org/listinfo/galette-discussion

Répondre à