Salut,

Le 12/11/2009 21:34, bdesroc...@free.fr a écrit :
> Je viens de me pencher sur le pb de la version de php.
> Donc, par défaut, c'est la version PHP Version 4.4.3-dev
> Mais en déposant un fichier .htaccess à la racine du site contenant php 5, 
> j'obtiens : PHP Version 5.1.3RC4-dev
>   

PHP4 n'est officiellement plus supportée depuis un moment déjà...
Quant à PHP5, on en est à la version 5.3 *stable* déjà :/
Me font bien marrer chez free avec une version 5.1*rc* :'( (à priori, la
version 5.1 finale de php est sortie en novembre 2005 !)

> Alors, maintenant, la question est de savoir que vaut-il mieux version 5 ou 
> version 4 ?
> Car en version 5, si j'envoie un mail j'obtiens maintenant une erreur Erreur 
> 500 - Erreur interne du serveur...
>   

Là c'est un autre problème, et sans avoir plus d'explications (voire des
messages d'erreur), il va être assez difficile d'y répondre.
À savoir : free n'autorise pas l'envoi de mails ; tout au moins avec la
fonction mail() de php.

> Damned
> Et maintenant il faut que je comprenne pourquoi je n'ai pas la version 0.63.2 
> d'installée !
>
>   

Je n'ai pas dit que la version installée n'était pas la 0.63.2.
J'ai oublié de modifier le numéro de version lors de la release de la
0.63.2 ; elle s'identifie donc comme une 0.63.1... Mais si tu sais
quelle version tu as récupérée sur le site, il n'y a pas de problème (de
toutes façons, le problème tel qu'énnoncé n'est pas spécifiquement en
rapport avec la sous version .2 à mon humble avis).

Johan

> Bruno Desroches
>
> ----- Mail Original -----
> De: "Johan Cwiklinski" <jo...@x-tnd.be>
> À: "Galette general discussion" <galette-discussion@gna.org>
> Envoyé: Jeudi 12 Novembre 2009 21h10:05 GMT +01:00 Amsterdam / Berlin / Berne 
> / Rome / Stockholm / Vienne
> Objet: Re: [Galette-discussion] Help. Envoi de mail impossible
>
> Salut,
>
> Le 12/11/2009 20:45, bdesroc...@free.fr a écrit :
>   
>> Bonsoir,
>>
>> je dois faire un mailing ce soir et voilà la réponse que j'obtiens à chaque 
>> essai :
>>
>> Fatal error: Call to undefined function: stripos() in 
>> /mnt/125/sdb/9/1/bdesroches/jda/includes/functions.inc.php on line 233
>>   
>>     
> Hum... Quelle est la version de php utilisée ? Il semblerait (selon la
> doc) que stripos soit apparue en php 5 et donc serait inexistante en
> php4. La version 0.63.x est *censée* être compatible php4 ; mais je
> n'utilise plus cette vieillerie depuis des années, je ne peux pas
> confirmer que ce soit effectivement le cas.
>
> Pour moi, ça ressemble à une mauvaise version de PHP...
>
>   
>> Je ne comprends pas du tout ce que cela peut signifier et surtout, je ne 
>> vois pas ce que je dois faire. Merci de m'aider, car c'est urgent !
>>   
>>     
> J'essaie d'aider de mon mieux, urgent ou pas ; pas la peine de cirer au
> loup (on connait tous le conte...).
>
>   
>> Je suis en dernière version stable 0.63.1 et hébergé chez free... 
>>   
>>     
> La dernière stable est la 0.63.2 (même si elle dit le contraire).
>
>   
>> Bruno Desroche
>>     
> Bonne soirée,
> Johan
>
>
> _______________________________________________
> Galette-discussion mailing list
> Galette-discussion@gna.org
> https://mail.gna.org/listinfo/galette-discussion
>
> _______________________________________________
> Galette-discussion mailing list
> Galette-discussion@gna.org
> https://mail.gna.org/listinfo/galette-discussion
>
>
>   


Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Galette-discussion mailing list
Galette-discussion@gna.org
https://mail.gna.org/listinfo/galette-discussion

Répondre à