Salut,

On Thu, 15 Dec 2011 13:03:32 +0100, "Charles Grant"
<charles.gr...@free.fr> wrote:
> Bonjour, 
> 
> Je cherche un logiciel de gestion d'association. Après quelques
> recherches, Galette me parait convenir parfaitement à mes besoins.
> MAIS, j'ai noté qu'il exige PHP 5.3 minimum. Mon serveur dédié chez
> OVH est en PHP 5.2.5. Je suis très réticent à me lancer dans cette
> migration (difficulté technique, compatibilité risquée des applis
> PHP déjà existantes, etc. .) Ma question : quelles seraient les
> conséquences de faire tourner Galette avec PHP 5.2.5 ? Est-ce
> possible, raisonnable, rédhibitoire ?  Ou me conseillez-vous plutôt
> de chercher un autre logiciel ? 

Galette 0.63 (bientôt en fin de vie) ne requiert pas PHP 5.3.

En ce qui concerne galette 0.7 (pas encore sortie) ; c'est un
pré-requis.
Comme expliqué dans la documentation
(http://galette.tuxfamily.org/documentation/fr/installation/#pre-requis-et-hebergement),
PHP 5.2 n'est plus supporté depuis un an déjà ; et PHP 5.4 est sur les
rails (la compatibilité est d'ailleurs dores et déjà assurée en ce qui
me concerne), ...

Utiliser Galette 0.7 avec un PHP < 5.3 ne marchera simplement pas ; et
rien n'est prévu en ce sens (j'y suis personnellement opposé, et je n'ai
de toutes façons pas la possibilité d'avoir un PHP 5.2 ; je tourne en
5.4).

> 
> Je suis totalement débutant avec Galette : merci de pardonner la
> naïveté de mes questions et merci surtout pour vos lumières. 
> 
> Charles G.

++
Johan

_______________________________________________
Galette-discussion mailing list
Galette-discussion@gna.org
https://mail.gna.org/listinfo/galette-discussion

Répondre à