Bonsoir Johan,

Que de péripéties aujourd'hui :-)

Je n'ai pas fait une mise à jour, mais une nouvelle install en ayant
d'abord changé le nom de l'ancien répertoire galette et en utilisant une
autre base. Donc je ne pense pas qu'il y ait pu avoir interférence entre
les 2 versions.

Je viens d'installer la dernière release 0.7.1.4. Toujours pareil :-(

Je me demande si dans les paramètres de config de PHP de l'hébergeur, il
n'y aurait pas une incompatibilité avec la nouvelle version de Smarty
(ou autre).
Voici à tout hasard le lien qui décrit la config de PHP du serveur : 
http://www.freewebhostingarea.com/phpinfo-default_variables.html

Pour info, j'ai mis des affichages dans index.php et c'est en exécutent
la ligne     
                        $tpl->display('public_page.tpl');
que l'erreur se produit. 
J'ai vu que sur la ligne 2 (soit disant en erreur) de public_page.tpl il
y a des variables qui sont utilisées. Est-ce que suivant la config du
serveur, les valeurs des variables pourraient ne pas être transmises ?

Je vais essayer de continuer à creuser dès que j'ai un peu de temps.

Sinon, quelqu'un pourrait-il me conseiller un hébergeur gratuit chez qui
je pourrais ouvrir un compte pour tenter une install ?
C'est dommage car pour la version 0.7.0, ça fonctionnait au poil chez
FreeWebHosting.

Merci et bonne soirée.
A+

Denis.

-----Message d'origine-----
De : galette-discussion-boun...@gna.org
[mailto:galette-discussion-boun...@gna.org] De la part de Johan
Cwiklinski
Envoyé : dimanche 7 octobre 2012 09:10
À : Galette general discussion
Objet : Re: [Galette-discussion] RE : RE : Problème execution galette
0.7.1

Salut,

Le 07/10/2012 00:07, Denis Capouillez a écrit :
> -
> Fatal error: Uncaught exception 'SmartyCompilerException' with message
> 'Syntax Error in template
>
"/home/vhosts/vsm.orgfree.com/galette/templates/default/public_page.tpl"
> on line 2 "<html lang="{$galette_lang}"

Heu... La ligne 2 de public_page.tpl *est* correcte, quoi qu'il en dise
:D Je suppose que tu n'as pas touché à autre chose dans le code qu'au
numéro de version de Smarty (ie. pas de tentatives de modifications des
pages, etc) ?

> class="public_page{if $additionnal_html_class}
> {$additionnal_html_class}{/if}">" unknown tag
> "private_print_expression"' in
>
/home/vhosts/vsm.orgfree.com/galette/includes/Smarty-3.1.12/sysplugins/s
> marty_internal_templatecompilerbase.php:657 Stack trace: #0
>
/home/vhosts/vsm.orgfree.com/galette/includes/Smarty-3.1.12/sysplugins/s
> marty_internal_templatecompilerbase.php(443):
> Smarty_Internal_TemplateCompilerBase->trigger_template_error('unknown
> tag "pr...', 2) #1
>
/home/vhosts/vsm.orgfree.com/galette/includes/Smarty-3.1.12/sysplugins/s
> marty_internal_templateparser.php(2353):
> Smarty_Internal_TemplateCompilerBase->compileTag('private_print_e...',
> Array, Array) #2
>
/home/vhosts/vsm.orgfree.com/galette/includes/Smarty-3.1.12/sysplugins/s
> marty_inte in
>
/home/vhosts/vsm.orgfree.com/galette/includes/Smarty-3.1.12/sysplugins/s
> marty_internal_templatecompilerbase.php on line 657
>
-----------------------------------------------------------------------
> 
> Bon il est un peu tard maintenant. Je regarderai de nouveau demain.

Je ne vois pas d'erreur, les templates sont OK pour moi.

Il me vient une idée... Un mix entre 0.7.0 et 0.7.1 pourrait avoir causé
un delta. Il faudrait essayer en supprimant d'abord tous les fichiers
contenus dans templates_c.

> 
> A+
> 
> Denis.

++
-- 
Johan



_______________________________________________
Galette-discussion mailing list
Galette-discussion@gna.org
https://mail.gna.org/listinfo/galette-discussion

Répondre à