Johan Cwiklinski <jo...@x-tnd.be> writes:
> Hello,
>
> Le 05/12/2012 22:45, lpelecq-...@circoise.eu a écrit :
>> Salut Johann,
>> 
>> Merci pour la correction. Ça marche. Il y a un autre problème dans
>> Repository/Membres.php. En version 8.4 la fonction concat n'existe
>> pas. Elle est apparue en 9.1. Est-ce qu'il y a une version minimale de
>> postgres supportée ?
>> 
>
> Arf... Ben, normalement, c'est censé fonctionner avec postgres 8 ; mais
> il semble bien que ce ne soit plus le cas depuis la version 0.7.
>
> À y regarder de plus près, il semble que j'utilise CONCAT mais aussi le
> "||" ; du coup, ce n'est pas très utile ; et ça ne devrait pas être trop
> compliqué à corriger (j'aurai ainsi la joie de sortir la troisième
> release de la semaine :D).
>
> Pourrais-tu essayer avec le patch joint ? N'hésites pas à ouvrir
> directement un bug dans ce genre de cas ;)
>
> À priori, c'est le seul endroit dans le code qui utilise CONCAT ; mais
> comme je travaille toujours avec une version assez récente de postgres
> (Fedora oblige :p), il est fort possible que d'autres incompatibilités
> aient été introduites.

Extra. Ça marche. S'il y a d'autres problèmes, on passera à la 9.1. Il
parait qu'elle est dispo dans les dépôts backport de debian.

Merci.

Laurent


_______________________________________________
Galette-discussion mailing list
Galette-discussion@gna.org
https://mail.gna.org/listinfo/galette-discussion

Répondre à