J'ai enlevé le fichier .htaccess et voici le message qui apparait :

Version min:GALETTE_PHP_MIN | Version:5.4.14
| compare:

Je pense que le contrôle ne bloque pas le reste de la lecture du fichier. Mais 
mes connaissances sont très limitées, je suis ce que l'on appel un 
développeur-copieur. Je reprend su code et je l'adapte.

Franck

----- Mail original -----
De: "f lebegue" <f.lebe...@free.fr>
À: galette-discussion@gna.org
Envoyé: Mardi 7 Mai 2013 10:36:03
Objet: Re: [Galette-discussion] Message d'erreur au lancement de la page de 
création (1ère utilisation)

Bonjour Johan,

Et encore merci.

Je viens de faire ce que tu as demandé et aucun message n’apparaît.

Je retrouve le même message qu'au départ mais quelques lignes plus loin, à 
savoir :

Parse error: syntax error, unexpected T_STRING, expecting 
T_CONSTANT_ENCAPSED_STRING or '(' in /galette/includes/galette.inc.php on line 
95

Je ne sais pas si cela t'aide ?

Franck

------------------------------------------------------------------------------------
Posted by Johan Cwiklinski on May 07, 2013 - 07:46:
Salut,

Le 06/05/2013 23:04, André Lefranc a écrit :
Qu'est-ce qu'il fort ce Johan !!!
 merci Johan

Bah... La force de l'habitude ; c'est pas comme si ce message précis
n'avait jamais été remonté ;)

Le 06/05/13 21:58, f.lebegue@xxxxxxx a écrit :
Merci de votre aide, le problème venait d'un fichier htaccess à la
racine de mon hébergement qui forçait le passage en php version
inférieure à 5.3

Ce qui n'est pas normal ; c'est qu'il y a une vérification de la version
de PHP quelques lignes au dessus. Ça aurait du gueuler :/

Franck, pourrais-tu remettre ton .htaccess en place, et ajouter
temporairement au fichier galette/includes/galette.inc.php, ligne 41
environ (en dehors des "if") les 3 lignes suivantes :
echo 'Version min:' . GALETTE_PHP_MIN;
echo ' | Version:' . PHP_VERSION . '<br/>';
echo ' | compare: ' . version_compare(PHP_VERSION, GALETTE_PHP_MIN, '<');

Tentes ensuite d'afficher Galette, tu devrais voir quelques messages
supplémentaires en plus de l'erreur que tu avais ; j'aurai besoin de ces
messages.

Tu pourras ensuite supprimer ces lignes, et retirer à nouveau le .htaccess.

Merci,
-- 
Johan

----- Mail original -----
De: "f lebegue" <f.lebe...@free.fr>
À: galette-discussion@gna.org
Envoyé: Lundi 6 Mai 2013 21:58:18
Objet: Re: [Galette-discussion] Message d'erreur au lancement de la page de 
création (1ère utilisation)

Merci de votre aide, le problème venait d'un fichier htaccess à la racine de 
mon hébergement qui forçait le passage en php version inférieure à 5.3

Franck

----- Mail original -----
De: "f lebegue" <f.lebe...@free.fr>
À: galette-discussion@gna.org
Envoyé: Lundi 6 Mai 2013 17:06:28
Objet: Re: Re: [Galette-discussion] Message d'erreur au lancement de la page de 
création (1ère utilisation)

Merci pour votre retour rapide,

Voici les informations complémentaires : 
- version de Galette : 0.7.4.1
- serveur : Hébergeur 1&1 avec PHP 5.4 et MYSQL5

Cela concerne la ligne :ligne 91 : use Galette\Common\ClassLoader;

Voilà j'espère que c'est suffisant.

Franck

_______________________________________________
Galette-discussion mailing list
Galette-discussion@gna.org
https://mail.gna.org/listinfo/galette-discussion

Répondre à