Salut,

J'envisage de modifier certains pré-requis de Galette (rien n'est arrêté
encore, mais j'y songe, de plus en plus).

Le premier point concerne le support de PostgreSQL. Actuellement, les
versions 8.4 et plus sont supportées ; j'envisage de passer à la version
9.1 minimum, notamment parce que « Group by peut deviner des colonnes
manquantes ».
La liste complète des nouveautés introduites dans cette version est
visible là :
http://wiki.postgresql.org/wiki/What%27s_new_in_PostgreSQL_9.1/fr

La version 9.1 de PostgreSQL est sortie en septembre 2011.

J'envisage aussi de porter la version minimale requise de PHP à 5.4. En
dehors des améliorations notables de performances, les traits peuvent
grandement me simplifier la vie, de même que les nouvelles notations de
tableaux.
La liste complète des nouveautés :
http://php.net/manual/fr/migration54.new-features.php

La version 5.4 de PHP est sortie en mars 2012. Il est à noter que PHP
5.3 est entré en cycle de fin de vie depuis mars 2013, et que plus
aucune nouveauté n'y est apportée, seuls demeurent les correctifs critiques.

Concernant PostgreSQL, c'est pour ainsi dire acté, les versions 0.7.5 et
0.7.5.1 ne sont déjà plus compatibles avec PostgreSQL < 9.1 (il s'agit
pour le moment d'anomalies, que je ne souhaite pas corriger).
J'envisage de modifier le support de Postgres pour Galette >= 0.7.5.

Concernant PHP, je pense que ça va faire grincer des dents (comme ça a
été le cas pour le support de PHP 5.3 minimum en son temps) ; mes
motivations sont les mêmes (nouveautés, performances et gain de temps de
développement).

Pour le moment, rien n'est changé. Si vous avez des remarques...

Nota : j'utilise au quotidien (perso et boulot) PostgreSQL 9.4.2/MariaDB
5.5.31 et PHP 5.5.3.

++
-- 
Johan

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Galette-discussion mailing list
Galette-discussion@gna.org
https://mail.gna.org/listinfo/galette-discussion

Répondre à