On Mon, Mar 11, 2013 at 03:21:03PM +0100, Michele Tartara wrote: > On Mon, Mar 11, 2013 at 3:15 PM, Iustin Pop <[email protected]> wrote: > > > On Mon, Mar 11, 2013 at 02:04:07PM +0100, Michele Tartara wrote: > > > On Mon, Mar 11, 2013 at 1:55 PM, Iustin Pop <[email protected]> wrote: > > > > > > > Hi all, > > > > > > > > While writing new test cases, I realised we can simplify entering test > > > > data heavily, if only we use OverloadedStrings. > > > > [...] > > > > So… bump hlint version (ugly), or don't use OverloadedStrings (ugly)? > > > > > > > > > > What kind of simplification would this allow us to introduce? Can you > > give > > > an example? > > > (I know what OverloadedStrings is needed for, in general, but I'm > > wondering > > > about the specific usage you have in mind) > > > > For example, before: > > > > Ip4Address 0 0 0 1 ==? nextIp4Address (Ip4Address 0 0 0 0) > > > > after (IMHO much more readable): > > > > "0.0.0.1" ==? nextIp4Address "0.0.0.0" > > > > and this is possibly a simple case. Basically one can remove > > constructors from data type declaration (in some cases, etc.). > > > > > Very nice! > My vote goes to bumping hlint version. Until recently we were keeping > pylint version back. I don't see pushing hlint forward to be worse than > that.
The downside would be that one won't be able to fully build Ganeti & run tests on a plain Wheezy machine, which was the goal… iustin
