After I ran out of  things to try, I went digging through apache's
error logs and found this gem:

PHP Fatal error:  Allowed memory size of 8388608 bytes exhausted
(tried to allocate 78 bytes) in /var/www/ganglia/ganglia.php on line

The (RedHat?) default of 8 MB can be changed in the main php.ini file
(usually in /etc) or you can override it in your web server
configuration file. I have broken out the settings for ganglia into a
separate apache config file, mine looks like this:

Alias /ganglia /var/www/ganglia

<Directory "/var/www/ganglia">
    Options None
    AllowOverride None
    Order allow,deny
    Allow from all
        #Configure PHP
        php_value memory_limit 32M

On 4/19/06, Martin Knoblauch <[EMAIL PROTECTED]> wrote:
> James,
>  cool. No need to be sorry. This is actually valuable information, as
> this may hit others as well.
>  How did you find out and where exactely is the php_value located in
> the config files?
> Thanks
> Martin
> --- James Trater <[EMAIL PROTECTED]> wrote:
> > I figured it out. I had assumed that it was a gmetad problem, but it
> > turned out to be a problem with PHP - specifically the amount of
> > memory that PHP is allowed to allocate. I put this in my apache
> > config
> > file for ganglia:
> >
> >         php_value memory_limit 32M
> >
> > and it works fine now. Sorry!
> >
> > Jim
> >
> >
> ------------------------------------------------------
> Martin Knoblauch
> email: k n o b i AT knobisoft DOT de
> www:

Reply via email to