------- Comment #5 from mikpe at it dot uu dot se  2010-09-05 10:07 -------
(In reply to comment #4)
> Subject: Re:  [4.6 regression] bootstrap failure on
>         sparc64-unknown-linux-gnu
> On Sat, Sep 04, 2010 at 01:38:34PM -0000, mikpe at it dot uu dot se wrote:
> > Can you show us the complete configure options you used?
> gcc63 is down at the moment for scheduled maintenance, so I can't quote
> exactly.  As best I can recall, it was:
> CC='gcc -m64' /path/to/configure --disable-lib{mudflap,ssp,gomp} \
>   --enable-languages=c --disable-nls --enable-threads=posix \
>   --with-mpfr=/opt/cfarm/mpfr-2.4.1-64 \
>   --with-gmp=/opt/cfarm/gmp-4.2.4-64 --with-mpc=/opt/cfarm/mpc-0.8-64

This is similar (modulo paths) to what I tried unsuccessfully to do.  The
problem was the "CC='gcc -m64'" override; somehow that caused the stage2
attempt to configure 32-bit zlib to fail because it passed a completely bogus
path to prev-gcc as CC.  The same error occurred when trying to build a pure
64-bit gcc-4.5.1, but it did work for building a 64-bit gcc-4.4.4.

I then used my 64-bit 4.4.4 to build a 64-bit 4.5.1 (just setting PATH, not
CC), and then the 64-bit 4.5.1 to build a 64-bit 4.6-r163858.  The last build
ICEd in stage2 when trying to build a 32-bit _muldi3 for libgcc:

/mnt/scratch/objdir/./gcc/xgcc -B/mnt/scratch/objdir/./gcc/
-B/mnt/scratch/install/sparc64-unknown-linux-gnu/lib/ -isystem
/mnt/scratch/install/sparc64-unknown-linux-gnu/include -isystem
/mnt/scratch/install/sparc64-unknown-linux-gnu/sys-include    -g -O2 -m32 -O2 
-g -O2 -DIN_GCC   -W -Wall -Wwrite-strings -Wcast-qual -Wstrict-prototypes
-Wmissing-prototypes -Wold-style-definition  -isystem ./include  -fPIC -g
-I../../.././gcc -I/mnt/scratch/gcc-4.6-r163858/libgcc
-I/mnt/scratch/gcc-4.6-r163858/libgcc/../libdecnumber -DHAVE_CC_TLS  -o
_muldi3.o -MT _muldi3.o -MD -MP -MF _muldi3.dep -DL_muldi3 -c
/mnt/scratch/gcc-4.6-r163858/libgcc/../gcc/libgcc2.c \
          -fvisibility=hidden -DHIDE_EXPORTS
/mnt/scratch/gcc-4.6-r163858/libgcc/../gcc/libgcc2.c: In function '__muldi3':
/mnt/scratch/gcc-4.6-r163858/libgcc/../gcc/libgcc2.c:558:1: internal compiler
error: in find_mem_expr_in_1pdv, at var-tracking.c:4120

I haven't attempted to bisect this yet.



Reply via email to