------- Comment #9 from marc dot glisse at normalesup dot org 2010-09-06 17:48
(In reply to comment #8)
> Draft patch, tested x86_64-linux
Nice. Just to confirm, that's indeed what I had in mind, except that I was
going to rename __is_iterator_helper to __has_iterator_category and move
"||is_pointer" from the helper to __is_iterator (and then use
__has_iterator_category for __iterator_traits). But it is equivalent.
Now to the hardest part: deciding whether to apply it ;-)