--- Comment #3 from Marc Glisse <glisse at gcc dot> ---
Copying from

"The way _mm_load_sd is currently implemented in gcc, yes, sanitizers are right
to complain. Intel could have named the thing _mm_loadu_sd if that's what they
meant. It would be simple to change if we decide to do so, please file a PR in

Workaround: define a typedef for double with __attribute__((__aligned__(1))),
and use _mm_set_sd(*(newtype*)p), that's how it will likely be done if we
change emmintrin.h."

Reply via email to