Tom de Vries <vries at gcc dot> changed:

           What    |Removed                     |Added
                 CC|                            |tschwinge at gcc dot

--- Comment #7 from Tom de Vries <vries at gcc dot> ---
(In reply to Richard Biener from comment #3)
> flags?  A simple ./xgcc -fopenacc doesn't reproduce it.  With my GCC 7
> install I see
> lto-wrapper: fatal error: problem with building target image for nvptx-none
> but no way to see the lto1 invocations :/ (tried -Wl,-debug -Wl,-v already)

I ran into the same problem when trying to use an installed compiler. Fixed by
adding -B options for:
- the dir containing accel/nvptx-none/mkoffload
- the dir containing the offload gcc (in my case,

$ ./install/bin/x86_64-pc-linux-gnu-gcc \
  -fopenacc \
  src/libgomp/testsuite/libgomp.oacc-c-c++-common/pr85422.c \
  -B $(pwd -P)/install/offload-nvptx-none/bin \
  -B $(pwd -P)/install/offload-nvptx-none/libexec/gcc/x86_64-pc-linux-gnu/8.0.1

The error message could certainly be be better.

Reply via email to