https://gcc.gnu.org/bugzilla/show_bug.cgi?id=127170
--- Comment #1 from Richard Biener <rguenth at gcc dot gnu.org> --- I think it's good for consistency that integer_* predicates support all of ANY_INTEGRAL_TYPE_P. So I would rather not change that. Maybe instead rename integer_pow2p to integer_cst_pow2p? For some reason it doesn't handle VECTOR_CST either. Or rename all integer_* to [any_]integral_*? Looking I see quite some inconsistencies :/
