On Thu, Jul 09, 2015 at 12:02:19PM +0200, Richard Biener wrote:
> I've added support for non-digit names to allow more descriptive
> patterns.  Like when we have
> 
> /* Fold (X << C1) & C2 into (X << C1) & (C2 | ((1 << C1) - 1))
>         (X >> C1) & C2 into (X >> C1) & (C2 | ~((type) -1 >> C1))
>    if the new mask might be further optimized.  */
> (for shift (lshift rshift)
>  (simplify
>   (bit_and (convert?@4 (shift@5 (convert1?@3 @0) INTEGER_CST@1)) 
> INTEGER_CST@2)
> 
> using @andop2 instead of @2 and @shift instead of @5 (etc.) might
> make the following code easier to follow.

All right, that makes sense.
 
> That everything uses digits right now is historic mostly (and
> my habit of using digits just because I got used to it).
> 
> But yes, with @a, @b vs. @0, @1 we should standardize on something
> (digits).
> 
> Richard.

        Marek

Reply via email to