On Wed, Aug 19, 2015 at 05:00:14PM +0100, Andrew Pinski wrote: > Just like the patch for AARCH64_FUSION_PAIR, this is a patch for > AARCH64_EXTRA_TUNING_OPTION. Note I tested this patch on top of the > patch for AARCH64_EXTRA_TUNING_OPTION. > > Changes in v2: > Remove the hack for AARCH64_EXTRA_TUNE_ALL. > > Remove index from AARCH64_EXTRA_TUNING_OPTION > > Instead of doing an explict index in aarch64-tuning-flags.def, we > should have an enum which does the index instead. This allows > you to add/remove them without worrying about the order being > correct and having holes or worry about merge conficts. > > OK? Bootstrapped and tested on aarch64-linux-gnu with no regressions.
-ENOPATCH, but assuming this is along the same lines as the one I just acked, I'm happy for you to consider this preapproved (after checking the comments below). Please send a copy to the list for the archives. > ChangeLog: > * config/aarch64/aarch64-tuning-flags.def: Remove all index to > AARCH64_EXTRA_TUNING_OPTION. > * config/aarch64/aarch64-protos.h (extra_tuning_flags_index): New enum. I'm guessing that this has a more aarch64-centric name like aarch64_extra_tuning_flags_index ? If not, it probably should have just to fit with the naming scheme in the rest of the file. > (aarch64_extra_tuning_flags): Base the shifted value on the index instead > of the argument to AARCH64_EXTRA_TUNING_OPTION. > * config/aarch64/aarch64.c: Remove the last argument to > AARCH64_EXTRA_TUNING_OPTION.. Watch out for the extra . on the end of this ChangeLog line.. Thanks, James >