On 04/19/2016 12:54 PM, Jakub Jelinek wrote: > Can you please: > rtx fpr = gen_rtx_REG (DImode, cfun_gpr_save_slot (i)); > if (i == STACK_POINTER_REGNUM) > insn = emit_insn (gen_stack_restore_from_fpr (fpr)); > else > insn = emit_move_insn (gen_rtx_REG (DImode, i), fpr); > That way IMHO it is more nicely formatted, you avoid the ugly ( > at the end of line, it uses fewer lines anyway and additionally > you can make it clear what the gen_rtx_REG (DImode, cfun_gpr_save_slot (i)) > means by giving it a name. Of course, choose whatever other var > name you prefer to describe what it is.
Right, that's better. I'll change the patch and commit it tomorrow. Thanks! -Andreas-