On 10/13/2016 05:52 PM, David Malcolm wrote:

Alternatively, it seems that we might want an additional flag for

Probably - I imagine most testcases won't care (it's obviously easier to read without locations) but some will. The writing side is maybe less interesting than the reading side, making sure we parse either variant correctly.

If so, maybe it's time to introduce a "class rtx_writer" or
similar to hold the global state relating to dumping, and rewrite
the dumping in those terms?

Depends how invasive that's going to be. I have no clear picture of it.


Reply via email to