On Tue, Aug 08, 2017 at 10:41:05AM -0600, Jeff Law wrote:
> On 08/05/2017 11:15 AM, Segher Boessenkool wrote:
> > For size cost I currently use just "length", but I haven't looked at
> > size cost much at all yet.
> I think that's fine. "length" is pretty standardized at this point and
> it's the right metric. For ports that don't bother defining a length
> attribute, punt in some reasonable manner.
I do this is in the target hook, not in generic code. Commonizing
two lines of code (at the cost of extra complexity for targets that
do *not* want to handle things that way) is not worth it IMO.