On Sun, Oct 16, 2011 at 1:12 AM, Andi Kleen <a...@firstfloor.org> wrote:
> From: Andi Kleen <a...@linux.intel.com>
>
> Some external tools special case __gnu_lto* symbols, and the new 
> __gnu_slim_lto
> was the only LTO symbol not matching this pattern. Since I don't think
> there are any users rename it to __gnu_lto_slim
>
> Passes bootstrap and test suite on x86_64-linux. Ok?

Ok.

Thanks,
Richard.

> Cc: hubi...@ucw.cz
>
> gcc/:
>
> 2011-10-13  Andi Kleen  <a...@linux.intel.com>
>
>        * toplev.c (compile_file): Rename __gnu_slim_lto to __gnu_lto_slim.
> ---
>  gcc/toplev.c |    6 +++---
>  1 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/gcc/toplev.c b/gcc/toplev.c
> index ab6b5a4..63e229e 100644
> --- a/gcc/toplev.c
> +++ b/gcc/toplev.c
> @@ -651,13 +651,13 @@ compile_file (void)
>         {
>  #if defined ASM_OUTPUT_ALIGNED_DECL_COMMON
>          ASM_OUTPUT_ALIGNED_DECL_COMMON (asm_out_file, NULL_TREE,
> -                                         "__gnu_slim_lto",
> +                                         "__gnu_lto_slim",
>                                          (unsigned HOST_WIDE_INT) 1, 8);
>  #elif defined ASM_OUTPUT_ALIGNED_COMMON
> -         ASM_OUTPUT_ALIGNED_COMMON (asm_out_file, "__gnu_slim_lto",
> +         ASM_OUTPUT_ALIGNED_COMMON (asm_out_file, "__gnu_lto_slim",
>                                     (unsigned HOST_WIDE_INT) 1, 8);
>  #else
> -         ASM_OUTPUT_COMMON (asm_out_file, "__gnu_slim_lto",
> +         ASM_OUTPUT_COMMON (asm_out_file, "__gnu_lto_slim",
>                             (unsigned HOST_WIDE_INT) 1,
>                             (unsigned HOST_WIDE_INT) 1);
>  #endif
> --
> 1.7.5.4
>
>

Reply via email to