On 3/6/19 3:05 AM, Richard Biener wrote:
> On Tue, Mar 5, 2019 at 10:36 PM Jeff Law <l...@redhat.com> wrote:
>>
>> On 3/5/19 7:44 AM, Richard Biener wrote:
>>
>>> So fixing it properly with also re-optimize_stmt those stmts so we'd CSE
>>> the MAX_EXPR introduced by folding makes it somewhat ugly.
>>>
>>> Bootstrapped on x86_64-unknown-linux-gnu, testing in progress.
>>>
>>> Any ideas how to make it less so?  I can split out making optimize_stmt
>>> take a gsi * btw, in case that's a more obvious change and it makes the
>>> patch a little smaller.
>>>
>>> Richard.
>>>
>>> 2019-03-05  Richard Biener  <rguent...@suse.de>
>>>
>>>         PR tree-optimization/89595
>>>         * tree-ssa-dom.c (dom_opt_dom_walker::optimize_stmt): Take
>>>         stmt iterator as reference, take boolean output parameter to
>>>         indicate whether the stmt was removed and thus the iterator
>>>         already advanced.
>>>         (dom_opt_dom_walker::before_dom_children): Re-iterate over
>>>         stmts created by folding.
>>>
>>>         * gcc.dg/torture/pr89595.c: New testcase.
>>>
>>
>> Well, all the real logic changs are in the before_dom_children method.
>> The bits in optimize_stmt are trivial enough to effectively ignore.
>>
>> I don't see a better way to discover and process statements that are
>> created in the bowels of fold_stmt.
> 
> I'm not entirely happy so I created the following alternative which
> is a bit larger and slower due to the pre-pass clearing the visited flag
> but is IMHO easier to follow.  I guess there's plenty of TLC opportunity
> here but then I also hope to retire the VN parts of DOM in favor
> of the non-iterating RPO-VN code...
> 
> So - I'd lean to this variant even though it has the extra loop over stmts,
> would you agree?
> 
> Bootstrap / regtest running on x86_64-unknown-linux-gnu.
> 
> Richard.
> 
> 2019-03-06  Richard Biener  <rguent...@suse.de>
> 
>         PR tree-optimization/89595
>         * tree-ssa-dom.c (dom_opt_dom_walker::optimize_stmt): Take
>         stmt iterator as reference, take boolean output parameter to
>         indicate whether the stmt was removed and thus the iterator
>         already advanced.
>         (dom_opt_dom_walker::before_dom_children): Re-iterate over
>         stmts created by folding.
> 
>         * gcc.dg/torture/pr89595.c: New testcase.
This one is easier to follow from a logic standpoint.  I don't think the
gimple_set_visited bits are going to be terribly expensive in general.

Is that flag in a known state for new statements?  I'm guessing it's
cleared by some structure-sized memset as we create the raw statement?

Might be worth clarifying that in the comments in gimple.h.

jeff

Reply via email to