Hi!

On Tue, Aug 11, 2020 at 12:23:05PM -0700, Carl Love wrote:
> +;; 128-bit int modes
> +(define_mode_iterator VEC_I128 [V1TI TI])

We already have VSX_TI for this (in vsx.md).  Rename that to something
without VSX, and move it to vector.md or such?  Maybe name it VEC_TI
or anyTI.

Do that renaming as a separate patch before this one?  It is logically
separate, and it is boring stuff, so putting it in a separate patch
makes the non-boring stuff stand out more.

(It would be better if we could just get rid of V1TI, but that isn't
going to happen soon).

> --- a/gcc/config/rs6000/vsx.md
> +++ b/gcc/config/rs6000/vsx.md
> @@ -367,7 +367,7 @@
>     UNSPEC_INSERTR
>     UNSPEC_REPLACE_ELT
>     UNSPEC_REPLACE_UN
> -     UNSPEC_XXSWAPD_V1TI
> +     UNSPEC_XXSWAPD_VEC_I128

Why not just UNSPEC_XXSWAPD?  And, why an unspec at all?


Segher

Reply via email to