"Joseph S. Myers" <jos...@codesourcery.com> writes:

> On Wed, 14 Mar 2012, Rainer Orth wrote:
>> Jason Merrill <ja...@redhat.com> writes:
>> > On 03/12/2012 01:41 PM, Joseph S. Myers wrote:
>> >> As a *target macro* it makes sense to remove it - reomve it from
>> >> defaults.h, make it purely internal to dwarf2out.c.  But I think it makes
>> >> sense to have it inside dwarf2out.c
>> >
>> > Agreed.
>> Here's the revised patch.  Bootstrapped without regressions on
>> i386-pc-solaris2.10, ok for mainline?
> No, I don't think you should simplify all the things you are simplifying 
> inside dwarf2out.c.  The initial length really is a function of the offset 
> size, not a magic constant 4, and the same applies to all the other things 
> you are changing: they are not constants in DWARF so should not be treated 
> as such.
> I think you should move the definition of DWARF_OFFSET_SIZE into 
> dwarf2out.c - with a comment that GCC doesn't generate 64-bit DWARF since 
> it's only needed if you have more than 2GB of debug info in a section in a 
> single .o file (or something like that) and not change anything else in 
> dwarf2out.c.

Ok, I'll leave that to one of the DWARF maintainers.  Patch withdrawn.


Rainer Orth, Center for Biotechnology, Bielefeld University

Reply via email to