File callgraph.c (right):
callgraph.c:513: const int section_priority[] = {0, 3, 4, 2, 1};
Add a comment about section_priority
callgraph.c:571: if (section_priority[kept->section_type]
Add an example that shows why we want to do that
callgraph.c:655: write_out_node (n_it->name, &section_start[0],
In write_out_node, why take the function name and do a hash table lookup
to get the section, instead of directly passing Section_id * in the
caller. In all calls to write_out_node, you are in fact getting the name
from the Section_id *.
callgraph.c:674: s_it->processed = 1;
setting processed to 1 is redundant as it is already done in
File callgraph.h (right):
callgraph.h:31: void push_mm_ptr (void *ptr);
push_allocated_ptr or save_allocated_ptr would be a better name.
callgraph.h:48: push_mm_ptr (list);
It might be cleaner to create a wrapper around XNEW that calls
push_mm_ptr after XNEW. Similar for malloc as well.

Reply via email to