On 5/5/26 09:01, Waffl3x wrote:
This is specifically for an allocator clause in an allocate directive.

The old text, 'allocator' clause allocator expression, does not flow very
well. This patch removes the redundant second allocator from the diagnostic.
This case reads poorly because the two words are the same, but there are
other diagnostics that use the same pattern that we could consider changing
as well. For example, 'allocate' clause allocator expression, despite being
two different words still feels rather redundant.

gcc/c/ChangeLog:

        * c-parser.cc (c_parser_omp_allocate): Change diagnostic.

gcc/testsuite/ChangeLog:

        * c-c++-common/gomp/allocate-5.c: Match new diagnostic.

Signed-off-by: Waffl3x <[email protected]>

OK. This patch qualifies as "obvious", too -- plus my documentation-maintainer-foo covers diagnostic messages.

-Sandra

Reply via email to