> From: Christophe Lyon <[email protected]> > Sent: Thursday, June 4, 2026 6:00 PM > > On 6/4/26 08:43, Haochen Jiang wrote: > > Hi all, > > > > Last year, contrib/compare_test introduces non-unique test name check. > > It is a good feature for new tests addition so that they will have no > > more same test names, which will help identify bugs more precisely. > > > > However, the legacy old tests got many non-unique names. This will > > result in compare_tests showing tons of lines for non-unique names > > at the beginning of the report. This actually reduced the readability > > report when I am testing new patches whether there are test regressions. > > > > This patch will not fix all the non-unique names (Definitely!). The fixed > > amount non-unique names is around 70-75%. Still about 1/4 remaining. But > > for a current 3400+ lines long non-unique name list for unix{-m32,-m64} > under > > x86_64, it is a big step. > > > > Sorry I wasn't aware of such big numbers! > I used arm and aarch64 reports, which for some reason didn't show that > many duplicates. > > A few months ago, Richard fixed several duplicates (in binutils too IIRC).
That is not your issue. The feature is definitely a good idea to identify different testcases more clearly or developer will be confused. Those non-unique names are the issue and need to be resolved. > > Do you have an example of the change for gdb/prettyprinters ? > Previously, it would be two same FAIL: libstdc++-prettyprinters/debug.cc print redirected since we did not put -flto into test name Now it will become two different names: FAIL: libstdc++-prettyprinters/debug.cc print redirected FAIL: libstdc++-prettyprinters/debug.cc -flto print redirected Thx, Haochen
