On Sat, 2026-06-13 at 10:38 +0800, Chenghua Xu wrote:
> Xi Ruoyao <[email protected]> writes:
> 
> Hi Ruoyao:
> 
> > A hot loop in SPEC 2026 stockfish_r calculates the dot product of a
> > sign-extended vector and a zero-extended vector.  Add the corresponding
> > usdot_prod pattern to use the instructions with such a semantic, for
> > example xvmulwev.h.bu.b, to optimize the loop.
> > 
> >     PR target/125474
> > 
> > gcc/
> > 
> >     * config/loongarch/simd.md (usdot_prod<wvec_half><mode>): New
> >     define_expand.
> >     (usdot_prod<wvec_quarter><mode>): New define_expand.
> 
> LGTM.
> 
> > gcc/testsuite/
> > 
> >     * g++.target/loongarch/pr125474.C: New test.
> 
> Plase move this test case to gcc.target/loongarch/vector/lasx directory and 
> rename it to lasx-dot-prod.C. You can put the PR number in the comments.

I think it's incorrect to have a C++ test case in g++.target?  I'll try
to rewrite it in C then.

-- 
Xi Ruoyao <[email protected]>

Reply via email to