On 6/29/2026 2:31 AM, Jakub Jelinek wrote:
Hi! In C23, the primary boolean spelling is bool rather than _Bool, which is just a backward compatibility thing. So, we shouldn't spell the type as _Bool in debug info (and in diagnostics) but as bool. Obviously, for C17 and earlier it should be _Bool. The following patch does that. Bootstrapped/regtested on x86_64-linux and i686-linux, ok for trunk? 2026-06-29 Jakub Jelinek <[email protected]> PR c/125935 * c-decl.cc (c_init_decl_processing): Use "bool" rather than "_Bool" as the name of boolean_type_node for C23+. * gcc.dg/debug/dwarf2/pr125935-1.c: New test. * gcc.dg/debug/dwarf2/pr125935-2.c: New test. * gcc.dg/debug/dwarf2/pr125935-3.c: New test. * gcc.dg/debug/ctf/ctf-bitfields-3.c: Expect bool rather than _Bool. * gcc.dg/Warray-bounds-65.c: Expect bool in diagnostics instead of _Bool. * gcc.dg/Wbad-function-cast-1.c: Likewise.
OK jeff
