On Mon, 6 Jul 2026, Martin Uecker wrote:

>     c: harmonize checking for flex array member type.
>     
>     We already have a helper function to detect the type of a flexible
>     array member.  Rename it for consistency and move it to tree.cc.
>     Also use the function for some additional cases instead of using a
>     direct test.  In digest_init the change removes the warning for
>     zero-sized arrays, but it is misleading and redundant as we already
>     warn for excess initializers (and with -Wpedantic also for the use
>     of zero-sized arrays).

OK.

-- 
Joseph S. Myers
[email protected]

Reply via email to