A merge request titled aarch64: intrinsics refactors was created by Karl Meakin
(karmea01) <[email protected]>.
It can be found at https://forge.sourceware.org/gcc/gcc/pulls/90.
Description:
Minor refactors and documentation improvements. NFCI
Testing done: `make check-gcc` and `make check-target`
ChangeLog:
* v1: Initial revision
* v2:
* Squash "aarch64: Remove redundant const from constexpr variables" and
"aarch64: Reformat array initializers to be more readable" into "aarch64:
Reformat array initializers"
* v3:
* Add "aarch64: Rename `ENTRY` to `DEF_SIMD_TYPE`"
* Squash "aarch64: Delete duplicate enum aarch64_simd_type definition" into
"aarch64: Rename `ENTRY` to `DEF_SIMD_TYPE`"
* Add "aarch64: Make `NUM_VECTOR_TYPES` an enum member"
* Add "aarch64: Use shifts in `aarch64_type_qualifiers` enum "
* v4: Rebase against master
* v5: Rebase against master
* v6: Fix compile error in "aarch64: Reformat array initializers"
* v7: remove `clang-format` directives
* v8: rebase against master, add "aarch64: use `enum unspec` rather than `int`"
* v9: rebase against master, split "aarch64: use `enum unspec` rather than
`int`" into
"use `unspec` type for unspec codes" and
"Replace `UNSPEC_NONE` with optional arguments where possible".
* v10: rebase against master. Change value of `UNSPEC_NONE` from `-1` to `0`.
CC: [email protected]
CC: [email protected]
CC: [email protected]
CC: [email protected]
CC: [email protected]
The merge request has been closed without being merged.
No discussion has taken place since its creation.