On Mon, Jul 27, 2026 at 04:42:42PM +0200, Josef Melcr wrote:
> I wasn't aware of the chain_index function when I first wrote the
> attribute handler for callback_only, so I implemented the functionality
> in get_nth_list_elem. This patch removes said function and replaces it
> with calls to chain_index to reduce code duplication.
>
> Best regards,
> Josef
>
> gcc/c-family/ChangeLog:
>
> * c-attribs.cc (get_nth_list_elem): Removed.
> (handle_callback_only_attribute): Use chain_index instead of
> get_nth_list_elem.
>
> Signed-off-by: Josef Melcr <[email protected]>
Ok.
Jakub