Hi Bohan, Yeah, common_vector_cost is another way to model this.
I’m just trying to make the cost-model rules clearer instead of hiding them in magic numbers. Otherwise, it may be hard to tell later whether a vector cost for a given uarch already includes the unit-ratio scaling. -- Regards, Zhongyao On Wed, Sep 2, 2026 at 5:01 PM Bohan Lei <[email protected]> wrote: > > Hi Zhongyao, > > I am not sure about the downstream implementation of other vendors, but > currently in the tune parameters of our design, we are modeling that with our > `common_vector_cost` instance with int_stmt_cost and fp_stmt_cost > greater than 1. I guess that can already suffice for many cases? Also, we > can have designs whose FP vector unit number is different than the integer > vector unit number, and we may still need to bother with the > `common_vector_cost` struct. > > Regards, > Bohan -- Regards, Zhongyao
