On Wed, Sep 2, 2026 at 4:18 PM Christopher Bazley <[email protected]> wrote: > > On 03/08/2026 14:07, Richard Biener wrote: > > On Thu, Jul 30, 2026 at 4:58 PM Christopher Bazley <[email protected]> > > wrote: > >> > >> These local variables existed before support for partial vectors > >> was added to the BB SLP vectorizer. Their loop-specific names > >> are no longer appropriate. > > > > Hmm, but with RVV we can have both masks and lens (not loop masks though), > > so a more distinctive name, maybe partial_with_mask_p and partial_with_len_p > > would be better. > > > > The former names are also consistently used I think, so just changing > > vectorizable_call > > does not look like an improvement. So I'd leave the names as-is, even > > if they are not > > a perfect fit now. > > > Hi Richard, > > after this patch series, the only other remaining uses of the former > names will be in supports_vector_compare_and_branch and > vectorizable_early_exit (which calls > supports_vector_compare_and_branch), i.e. in functions that only operate > on an instance of loop_vec_info. > > This final patch aligns the identifiers used within vectorizable_call > with those already used within vectorizable_operation, > vectorizable_load, vectorizable_store and vectorizable_condition. > Leaving the identifiers used by vectorizable_call as-is seems anomalous > to me. > > I don't have a strong opinion about partial_with_mask_p and > partial_with_len_p but I tend to prefer mnemonic names for local > variables, where sensible.
I see, but the description of the change said nothing like this. I agree that consistency trumps a good name (my point on that stands though). Grepping trunk on masks_p or lens_p shows no hits though, but masked_loop_p and use_masks_p shows uses, so maybe I am misunderstanding here. Richard. > -- > Christopher Bazley > Staff Software Engineer, GNU Tools Team. > Arm Ltd, 110 Fulbourn Road, Cambridge, CB1 9NJ, UK. > http://www.arm.com/
