Quentin Neill <quentin.neill....@gmail.com> writes: > Hi, > > For readability (and correctness) I'm interested in rewriting a bunch of: > > (define_insn_reservation "insn1" 0 (eq_attr "attr1" "val1,val2")) > > into something like: > > (define attr "consattr1" "val1,val2" > (const (cond [ > (eq_attr "attr1" "val1") (const_string "cvaly") > (eq_attr "attr1" "val2") (const_string "cvaly")] > (const_string "cvaln")))) > > (define_insn_reservation "insn1" 0 (eq_attr "consattr1" "cval"))
The general idea should work, but I don't think the (cond ...) should be wrapped in a (const ...) Richard