In message <[EMAIL PROTECTED]>
Lee <[EMAIL PROTECTED]> wrote:
> I believe the __som_got__ symbol is causing some problems because it is
> automatically being hidden by version scripts when it should be
> exported. This is because is starts with an underscore, which I used to
> emphasize the fact that it's a system symbol. I could rename it to
> som___got, which unfortunately brings it into the user namespace, but I
> think the use of 3 underscores in the middle should ensure that it
> doesn't clash with any user symbols.
I think it would be a benefit not to have need to have a __som_got__ (or
other similar named) symbol pointing to the start of the GOT. Why is it
that we (RISC OS port) need it and AFAICS other platforms don't ?
John.
--
John Tytgat, in his comfy chair at home BASS
[EMAIL PROTECTED] ARM powered, RISC OS driven
_______________________________________________
GCCSDK mailing list [email protected]
Bugzilla: http://www.riscos.info/bugzilla/index.cgi
List Info: http://www.riscos.info/mailman/listinfo/gcc
Main Page: http://www.riscos.info/index.php/GCCSDK