I am trying the autobuilder for the first time. I am using Linux Mint and I
seem to have downloaded and compiled GCCSDK successfully. I built a little
program of "Hello, world" complexity,compiled it, and ran it successfully on
RISC OS.

Next I tried to set up a new package for the autobuilder to build. I am
trying gpsbabel, which converts between various geodata file formats. I'm not
sure how far I'll get as I'll need to avoid compiling the Qt-based GUI and
just do the command-line version. Anyhow, I set up a very basic setvars whose
only active lines are:

AB_GIT=https://github.com/gpsbabel/gpsbabel.git
AB_ROVERSION=1
AB_PRECONF=:
AB_INSTALL=no

(I realise this may well not be sufficient.)

I then tried
./build -d cli/gpsbabel

It started building support/native-zip for me, and succeeded with various
patches. Then it started on configure, and got through that. Then make was
invoked, entering ./autobuilder/native-zip/zip30

I was expecting it to be built inside ./autobuilder/support/native-zip rather
than ./autobuilder/native-zip -- I don't know if that is a problem.

Then the C compiler started giving errors:

In file included from unix/osdep.h:31:0,
                 from tailor.h:93,
                 from zip.h:88,
                 from zipfile.c:16:
/home/matthew/gccsdk/cross/lib/gcc/arm-unknown-riscos/4.7.4/../../../../arm-unkn
own-riscos/include/sys/stat.h:117:1: error: redefinition of 'struct stat'
In file included from acorn/osdep.h:9:0,
                 from tailor.h:80,
                 from zip.h:88,
                 from zipfile.c:16:
acorn/riscos.h:30:8: note: originally defined here

There were a couple like that and also "conflicting types for 'stat'", and a 
complaint about chmod:

In file included from unix/osdep.h:31:0,
                 from tailor.h:93,
                 from zip.h:88,
                 from zip.c:16:
/home/matthew/gccsdk/cross/lib/gcc/arm-unknown-riscos/4.7.4/../../../../arm-unkn
own-riscos/include/sys/stat.h:241:12: error: conflicting types for 'chmod'
In file included from acorn/osdep.h:9:0,
                 from tailor.h:80,
                 from zip.h:88,
                 from zip.c:16:
acorn/riscos.h:106:5: note: previous declaration of 'chmod' was here

and then it finished:

make[1]: *** [zipfile.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: *** [zip.o] Error 1
make[1]: Leaving directory `/home/matthew/gccsdk/autobuilder/native-zip/zip30'
make: *** [generic] Error 2

I wonder whether the code has changed and needs more patching somehow? There
is something in configure to check if a 64-bit stat is supported and the
struct definitions differ if that's available. Zip contains its own RISC OS
specific header file containing stat.

I assume I need to get this fixed before I can proceed to the next stage of
failing abysmally to cross-compile gpsbabel. Can anyone suggest what to do
next?

Out of interest I've had a look at
http://ci.riscos.info/job/packages/job/native-zip/5/console This also failed,
but for different reasons. In the configure stage it had:

Check for Large File Support
  off_t is 8 bytes
-- yes we have Large File Support!

whereas on my machine I got

Check for Large File Support
./conftest: 1: ./conftest: Syntax error: word unexpected (expecting ")")
-- no Large File Support - no 64-bit stat

It looks like the Large File Support decision is not being made correctly, as
I would have expected it to be "no" for RISC OS. This means on Jenkins
-DLARGE_FILE_SUPPORT is passed to the C compiler. For whatever reason that
seems to avoid the duplicated stat definition problem, but the Jenkins build
fails at the end with

Archiving artifacts
ERROR: No artifacts found that match the file pattern 
"autobuilder/autobuilder_packages/**, autobuilder/autobuilder_libraries/**". 
Configuration error?
Build step 'Archive the artifacts' changed build result to FAILURE
[WS-CLEANUP] Deleting project workspace...[WS-CLEANUP] done
Finished: FAILURE


Thanks,

Matthew

-- 
Matthew Phillips
Durham

_______________________________________________
GCCSDK mailing list gcc@gccsdk.riscos.info
Bugzilla: http://www.riscos.info/bugzilla/index.cgi
List Info: http://www.riscos.info/mailman/listinfo/gcc
Main Page: http://www.riscos.info/index.php/GCCSDK

Reply via email to