In message <5605f55f4echr...@care4free.net>
 on 29 Jan 2017 Chris Gransden  wrote:

> In article <399fb40556.matt...@sinenomine.freeserve.co.uk>,
>    Matthew Phillips <spam20...@yahoo.co.uk> wrote:
> 
> > $ cd build
> > $ ../autobuilder/build -v wget
> 
> > as instructed. As with gpsbabel the first thing it tries to do is fetch
> > and compile native-zip. Again, after doing the patching, make starts and
> > we get the same errors as before:

[snip]
 
> native-zip should be getting built by the host compiler but instead it
> looks like the autobuilder installed compiler is being used.
> Have you set any envionment variables? Does echo $CC output anything.
> Are any of the autobuilder folders in your PATH? e.g.
> /home/matthew/gccsdk/env. 

Again, it was a result of my being stupid.  I had been reading a posting on
the ROOL forum in which someone sought advice on getting started with GCCSDK
(see https://www.riscosopen.org/forum/forums/11/topics/6289 ) and the fifth
posting, from Jeffrey Lee, suggested doing:

cd path/to/gccsdk
source env/ro-path

The second time I was vaguely aware this was not necessary but had run it to
check what needed to go in build-setvars and stupidly used the same shell for
the next steps.

Anyway, with a fresh shell I have now tried:

cd ~/gccsdk/build
../autobuilder/build -v wget

I get a report which concludes with:

Package wget: Success

This looks quite promising.  I tried to locate the compiled wget, but when I
looked in ./gccsdk/autobuilder/network/wget there was a !Wget but nothing
executable in it.  Using the Unix find command did not locate it.

I have now found in ./gccsdk/autobuilder/autobuilder_packages/Network that a
new wget_1.18-2.zip had been created and inside Apps.Network.!Wget there is a
wget executable.  So I think everything is OK.

I then managed to update my autobuilder installation to pick up your new
commits relating to gpsbabel

I tried running

cd ~/gccsdk/build
../autobuilder/build -v gpsbabel

It starts by trying Qt5Base, but this fails, and if I grep the last-failure
file for "error" case insensitively I get these lines at the end:

/home/matthew/gccsdk/cross/lib/gcc/arm-unknown-riscos/4.7.4/../../../../arm-unknown-riscos/bin/ld:
 error: 
/home/matthew/gccsdk/env/lib/libQt5PlatformSupport.a(qgenericunixeventdispatcher.o)
 uses FPA instructions, whereas libqminimal.so does not
/home/matthew/gccsdk/cross/lib/gcc/arm-unknown-riscos/4.7.4/../../../../arm-unknown-riscos/bin/ld:
 error: 
/home/matthew/gccsdk/env/lib/libQt5PlatformSupport.a(qunixeventdispatcher.o) 
uses FPA instructions, whereas libqminimal.so does not
collect2: error: ld returned 1 exit status
make[4]: *** [../../../../plugins/platforms/libqminimal.so] Error 1
make[3]: *** [sub-minimal-make_first] Error 2
make[2]: *** [sub-platforms-make_first] Error 2
make[1]: *** [sub-plugins-make_first] Error 2
make: *** [sub-src-make_first] Error 2


Do you have any further suggestions?  It looks like a build incompatibility
between a couple of components to do with the floating point.

> You can download gpsbabel from
> http://www.riscosports.co.uk/gpsbabel_1.5.3-1.zip. It also depends on
> Qt5Base being installed. If you use PackMan to install it the rest of the
> dependencies will be installed as well.

I've installed this successfully and tried converting a file. It seems to
work, but one of the points ended up with a latitude of "nan" rather than a
number, and that caused RiscOSM to crash when loading it.  (Obviously we need
to make RiscOSM more robust in case this happens.)

Not sure why this happened: a version of the file supplied to us converted by
the online gpsbabel web site was identical for all the other 4213 lines in
the file, but has a sensible number for the latitude for this point.

So, almost perfect!

-- 
Matthew Phillips
Durham

_______________________________________________
GCCSDK mailing list gcc@gccsdk.riscos.info
Bugzilla: http://www.riscos.info/bugzilla/index.cgi
List Info: http://www.riscos.info/mailman/listinfo/gcc
Main Page: http://www.riscos.info/index.php/GCCSDK

Reply via email to