On 11 April 2018 at 00:21, John Ballance <j...@macpcrepair.co.uk> wrote:
> For what it is worth, in setvars,
>
> AB_URL:http://archive.ubuntu.com/ubuntu/pool/main/libp/libpng/libpng_1.2.54.orig.tar.xz
>
> builds fine
>
> Agreed.. now target of libpng16 sounds a good idea
>
> JB
>
>
> On 10/04/2018 23:08, Ron wrote:
>
> In article <20180410214222.gd23...@chiark.greenend.org.uk>,
>    Theo Markettos <t...@markettos.org.uk> wrote:
>
> On Tue, Apr 10, 2018 at 10:35:15AM +0200, Michael Grunditz wrote:
>
> Autobuilder: Using existing Sources.gz (testing/main)
> Autobuilder: Using existing Sources.gz (testing/contrib)
> Autobuilder: Using existing Sources.gz (stable/main)
> Autobuilder: Using existing Sources.gz (stable/contrib)
> Autobuilder: Searching for libpng12-0 in ../Sources-testing-main.gz...
> Autobuilder: Searching for libpng12-0 in ../Sources-testing-contrib.gz...
> Autobuilder: Searching for libpng12-0 in ../Sources-stable-main.gz...
> Autobuilder: Searching for libpng12-0 in ../Sources-stable-contrib.gz...
> AutoBuilder: Package not found
> Package libpng12-0: ***Failure***
> Build for package "libpng12-0" failed
>
> Where is libpng?
>
> It seems like Debian have moved to libpng16, which is why it's not finding
> any sources.  It's in the 'oldstable' distro.  You can:
>
> Change autobuilder/fetch-program line:
>   distros="testing stable"
> to be:
>   distros="testing stable oldstable"
>
> but the longer term solution is to fix up the build for the current Debian
> package which is libpng16-16.  This may have implications if what you're
> trying to build will only work with libpng 1.2 not 1.6
>
> Theo
>
> I sent a post to gcc@sdk.riscos ,info last night outlining how to get
> libpng12, but I dont see it showing this morning.
> I changed the default Pluto of replying to the OP and CCing  to
> gcc@gccsdk.riscos.info maybe I introduced a typo
>
>
> Anyway continuing on from Theo, wouldn't we now make a new autobuilder
> package called libpng16 and leave the old one until it is no longer needed?
> Using (build unverified) one line
> AB_URL=http://http.debian.net/debian/pool/main/libp/libpng/
> libpng_1.2.50.orig.tar.xz
> would keep it going  for a while.
>
I would like to add that freetype 2.8.1 gives me a ICE, but earlier
versions works fine.

Part of SDL ttf dependence

_______________________________________________
GCCSDK mailing list gcc@gccsdk.riscos.info
Bugzilla: http://www.riscos.info/bugzilla/index.cgi
List Info: http://www.riscos.info/mailman/listinfo/gcc
Main Page: http://www.riscos.info/index.php/GCCSDK

Reply via email to