Hi,

Hexagon released ECW SDK 5.4 [1] with support for the CXX11 ABI, which
makes it compatible with gcc >= 5.1 with its default ABI.

I've just added support in configure in trunk and 2.2 branch to detect if we
must link against the libNCSEcw with the newabi or the one with the oldabi

Note: I've found that if you also link against the Teigha libraries, the ECW 
driver
tends to crash. The joy of combining two proprietary closed-source SDKs...

Even

[1] 
https://download.hexagongeospatial.com/downloads/ecw/erdas-ecw-jp2-sdk-v5-4-linux


-- 
Spatialys - Geospatial professional services
http://www.spatialys.com
_______________________________________________
gdal-dev mailing list
gdal-dev@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/gdal-dev

Reply via email to