Here it is the diff file that changes the "class" property to
"operation". I found a little problem while doing this, the "Gegl_node"
object already had a property named "operation", so I renamed that to
"gegl_operation". 

Also I tried to make sure that this remained backward compatible, with
bath the XML format and the API. With this patch the library will warn
the user when he uses a "class" property advising him to change it to
"operation". 

I test this with the gegl-demo applications and XML files and it all
went fine. Well there were lots and lots of warnings, but all the output
were okay. 

Attachment: class_to_operation.diff.bz2
Description: application/bzip

_______________________________________________
Gegl-developer mailing list
[email protected]
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gegl-developer

Reply via email to