-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://reviews.m5sim.org/r/741/#review1310
-----------------------------------------------------------


This seems reasonable to me, but we should consider if the old name was the 
actual name given by the architecture. I'm not that familiar with Alpha so I 
have no idea. If it was, then you could do something like "dfault (paging)" and 
"dfault (perm)" or similar and preserve the old name for the sake of looking 
things up in a manual.

- Gabe


On 2011-06-08 23:25:03, Korey Sewell wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://reviews.m5sim.org/r/741/
> -----------------------------------------------------------
> 
> (Updated 2011-06-08 23:25:03)
> 
> 
> Review request for Default, Ali Saidi, Gabe Black, Steve Reinhardt, and 
> Nathan Binkert.
> 
> 
> Summary
> -------
> 
> alpha: naming for dtb faults
> Just "dfault" gets confusing while debugging. Why not
> differentiate whether it's an access violation or page
> fault
> 
> 
> Diffs
> -----
> 
>   src/arch/alpha/faults.cc 77d12d8f7971 
> 
> Diff: http://reviews.m5sim.org/r/741/diff
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Korey
> 
>

_______________________________________________
gem5-dev mailing list
gem5-dev@m5sim.org
http://m5sim.org/mailman/listinfo/gem5-dev

Reply via email to