Korey, try 'hg status'. It would list the set of files that are not being tracked. May be there is some file that should be committed and has not been.

--
Nilay


On Thu, 9 Jun 2011, Korey Sewell wrote:

My local repo has this at the tip:
hg tip
changeset:   8342:77d12d8f7971
tag:         tip
user:        Korey Sewell <ksew...@umich.edu>
date:        Thu Jun 09 01:34:06 2011 -0400
summary:     sparc: compilation fixes for inorder

and the "hg outgoing" tab says nothing outstanding.

I have not tried this on zizzer yet, but that is the next step.

On Thu, Jun 9, 2011 at 6:02 PM, Steve Reinhardt <ste...@gmail.com> wrote:

It fails for me... are you sure you've pushed everything?  Have you
tried it on zizzer?

Steve

On Thu, Jun 9, 2011 at 1:36 PM, Korey Sewell <ksew...@umich.edu> wrote:
ok, this is a bit wierd.

I'm running all the tests locally and they are passing ...

Even the O3 one:

build/SPARC_SE/tests/opt/quick/40.m5threads-test-atomic/sparc/linux/o3-timing-mp

On Thu, Jun 9, 2011 at 1:52 PM, Korey Sewell <ksew...@umich.edu> wrote:

Yup, that's me. I will update the stats for the simple cpus. I thought I
had caught the branchTarget() error before, but apparently not.


On Thu, Jun 9, 2011 at 1:45 PM, Steve Reinhardt <ste...@gmail.com>
wrote:

Looks like all the SPARC tests failed.  The two o3-timing ones have
this
error:

panic: StaticInst::branchTarget() called on instruction that is not a
PC-relative branch.
[branchTarget:build/SPARC_SE/cpu/static_inst.cc, line 99]

The others seem to have run correctly, but have stats differences like
this:

 system.cpu.num_conditional_control_insts          0        774
 774  +9999.00%
 system.cpu.num_func_calls               0        146        146
 +9999.00%

I'm guessing this is from Korey's recent SPARC change...

Steve


_______________________________________________
gem5-dev mailing list
gem5-dev@m5sim.org
http://m5sim.org/mailman/listinfo/gem5-dev

Reply via email to