I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please resolve these comments along with any other Last Call comments
you may receive.


Document: draft-adolf-dvb-urn-00.txt
Reviewer: Miguel Garcia <[EMAIL PROTECTED]>
Review Date: 2007-10-09
IETF LC End Date: 2007-10-31

Summary: The document is almost ready for publication as an Informational RFC. There are a few nits that could be polished.

Comments:

- I am surprised that the document includes only one reference (to RFC
2141). In particular, I am missing a reference to RFC 3406 (URN namespace definition mechanism). Perhaps the Introduction section should add a sentence indicating that the document follows the registration process specified RFC 3046. At least the document correctly follows the registration procedure of RFC 3406.

- Section 2, "Declaration of structure" indicates that the URN will
contain US-ASCII characters. Is this correct? I think it would be better
to refer directly to the syntax in RFC 2141 without having the US-ASCII
characters as a "strange intermediary".

So, I would like the authors to consider to replace the current text:

      URNs assigned by DVB will have the following hierarchical
      structure based on the organizational structure of the DVB
      standards:

         urn:dvb:{assigned US-ASCII string}

      where "{assigned US-ASCII string}" is a US-ASCII string that
      conforms to URN Syntax requirements ([RFC2141]).


with this other text:

      URNs assigned by DVB will have the following hierarchical
      structure based on the organizational structure of the DVB
      standards:

         urn:dvb:{NSS}

      where the syntax of "{NSS}" is specified in Section 2.2 of the URN
      Syntax requirements ([RFC2141]).

- Section 7, IANA considerations section, could be a bit more clear if
it said:

This document defines a URN NID registration of "dvb". IANA is request to include it in the URN Namespaces registry.


- Section 8.1, the existing reference to RFC 2141 fails to mention "RFC
2141".

So, replace:
   [RFC2141]  Moats, R., "URN Syntax", May 1997.
with:
   [RFC2141]  Moats, R., "URN Syntax", RFC 2141, May 1997.

- On the front page, the author affiliation looks a bit strange, and it
is different from that in the last page. Also, the number of authors in
the first and last page differ.


/Miguel

______________________________
--
Miguel A. Garcia           tel:+358-50-4804586
Nokia Siemens Networks     Espoo, Finland





_______________________________________________
Gen-art mailing list
[email protected]
https://www1.ietf.org/mailman/listinfo/gen-art

Reply via email to