Thanks for your comments.  I'll include the following in -07 when it is posted.

Section 3 changes:

       Encryption:         Advanced Encryption Standard (AES) [AES] -
                           FIPS 197 (with keys sizes of 128 and 256
                           bits)

       Digital Signature:  Elliptic Curve Digital Signature Algorithm
                           (ECDSA) [DSS] - FIPS 186-2 (using the
                           curves with 256 and 384-bit prime moduli)

       Key Exchange:       Elliptic Curve Diffie-Hellman (ECDH) - NIST
                           Special Publication 800-56A [PWKE] (using the
                           curves with 256 and 384-bit prime moduli)

       Hashing:            Secure Hash Algorithm - FIPS 180-2 [SHS]
                           (using SHA-256 and SHA-384)

Section 4 changes:

   TLS version 1.1 [RFC4346] and earlier does not support Galois Counter
   Mode (GCM) cipher suites [RFC5289].  However, TLS version 1.2
   [RFC5246] and later does support GCM.  For Suite B TLS compliance,
   GCM cipher suites are REQUIRED to be used whenever possible.  Also,
   for Suite B TLS compliance, Cipher Block Chaining (CBC) cipher suites
   are employed when GCM cipher suites cannot be employed.

Thanks,
  Russ

At 10:24 AM 9/30/2008, Miguel A. Garcia wrote:
I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please resolve these comments along with any other Last Call comments
you may receive.


Document: draft-rescorla-tls-suiteb-06.txt
Reviewer: Miguel Garcia <[EMAIL PROTECTED]>
Review Date: 2008-09-30
IETF LC End Date: 2008-10-23

Summary: The document is ready for publication as an Informational RFC

Comments:
I just have a comment: The reader would appreciate if references are added at the first appearance of a specification. This includes:

+ Section 3, references to FIPS 197, FIPS 186-2, Draft NIST Special Publication 800-56, FIPS 180-2.

 + Section 4, references to TLS version 1.1 and TLS version 1.2

/Miguel

--
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain


_______________________________________________
Gen-art mailing list
[email protected]
https://www.ietf.org/mailman/listinfo/gen-art

Reply via email to