Miguel -
Many thanks for the review.
I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
Please resolve these comments along with any other Last Call comments
you may receive.
Document: draft-ietf-dccp-ccid4-04.txt
Reviewer: Miguel Garcia <[email protected]>
Review Date: 6-June-2009
IETF LC End Date: 22-June-2009
Summary: The document is ready for publication as an experimental
RFC. I have one question with respect to the IANA registration of
new codes (see below)
Major issues: none
Minor issues:
- In Sections 14.1, 14.2, 14.3, etc., the draft indicates that the
IANA registration of new codes requires "IESG review, approval, and
standards-track IETF RFC publication". Considering that THIS draft
is in the experimental category, is it reasonable to ask future
codes to be on the standards (and not experimental) track for
registration of new codes. In other words, this draft does not even
qualify itself for registration of its own codes!
I think the policy should be according to "Specification
Required" (see RFC 5226.
I added a sentence to Section 14, regarding the CCID codepoint,
saying that "This is a permanent codepoint, as is needed for
experimentation across the Internet using different codebases."
(Borrowing from Lars' email earlier today.)
There is a history in Transport of protocols that start as Experimental
but with different ranges of deployment in the Internet being
explicitly ok. Examples include NewReno TCP (RFC 2582, obsoleted
by RFC 3782), ECN (RFC 2481, obsoleted by RFC 4774), and TCP initial
windows (RFC 2414, obsoleted by RFC 3390). RFCs that remain as
Experimental (but with deployment allowed in the Internet) include
HighSpeed TCP (RFC 3649). Most of these didn't require anything
from IANA one way or another.
For CCID4, with the need for permanent codepoints, it seems reasonable
to require IANA registration allocated with the "Standards Action"
policy.
Nits/editorial comments:
- A Caption to the figure in Section 8.7 would be nice. For example:
"Figure 1: Dropped Packets Option". The same applies to the two
figures in Section 8.7.1.
Thanks, done.
- Sally
http://www.icir.org/floyd/
_______________________________________________
Gen-art mailing list
[email protected]
https://www.ietf.org/mailman/listinfo/gen-art