--------------------------------------------------
From: "Ludmila Shikhvarg" <ludmila.shikhv...@oracle.com>
Sent: Monday, November 08, 2010 5:47 PM
To: <general@gump.apache.org>
Subject: compatibility issue

Hi,

I'm a new gump user and started to use gump for jdk compatibility testing.
I'm using gump source from https://svn.apache.org/repos/asf/gump/trunk/ (use http://gump.apache.org/gettingstarted.html as a reference) with different build of jdk7 from https://jdk7.dev.java.net/index.html
Some projects (exp: junit, hamcrest) are failed to build due to:
[javac] javac: target release 1.5 conflicts with default source release 1.7

Is it a known issue?
Where can I report any issues related to jdk7?


Welcome to the Gump community!

Gump doesn't normally override these properties (and doesn't for the two projects you mentioned). So normally you have to contact the projects themselves and lobby to change their build settings. The main purpose of Gump is to give projects warning that changes down the road will cause them to break, so what you are doing fits with Gump. The junit project has generally been responsive to changes, but haven't worked with hamcrest. Since both the projects you mentioned are Ant builds, another possibility is to lobby Ant to change their defaults. The mailing list for that is d...@ant.apache.org. However, since I'm not really involved with Ant personally, I don't know what their community feels about such a change. It is possible that Stefan can weigh in on that if he wants to.

Thanks,
Ludmila


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscr...@gump.apache.org
For additional commands, e-mail: general-h...@gump.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscr...@gump.apache.org
For additional commands, e-mail: general-h...@gump.apache.org

Reply via email to