Stefan Bodewig wrote:
On 2011-02-21, Ludmila Shikhvarg wrote:

Stefan Bodewig wrote:
On 2011-02-18, Ludmila Shikhvarg wrote:

Building project commons-configuration fails:

[INFO] Failed to resolve artifact.
Missing:
----------
1) org.apache.commons:commons-vfs2:jar:2.0-SNAPSHOT
Try downloading the file manually from the project website.

This jar is built and installed by the commons-vfs2 project and this
works well for the ASF installations.

Does commons-vfs2 not build in your environment or have you modified the
commons-configuration descriptor?  Is your Gump installation public so
that we can see logs?

commons-vfs2 is build successfully in my environment. The Gump
installation is not public, but the log file is attached:


[INFO] Scanning for projects...
Downloading: 
http://localhost:80/maven2/org/apache/commons/commons-parent/17/commons-parent-17.pom

Is there a Maven repository proxy running at this port and does Gump
know about it?

If you are not using the proxy (I'm talking about
<https://svn.apache.org/repos/asf/gump/mvnrepo/>) then
commons-configuration cannot see the jar because it doesn't get
installed locally.

I don't recall the exact reason but I think there was some kind of
dependency cycle that made us put commons-configuration into a separate
local repository so even if commons-vfs2 used the install goal
commons-configuration still wouldn't see it.

Let's check you are sucessfully running the proxy before we try to find
a different solution.
Seen the same results with Maven repository proxy setup.
Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscr...@gump.apache.org
For additional commands, e-mail: general-h...@gump.apache.org


Reply via email to