Hi Fabian,

I do not recall changing make.conf file, before I started getting issues, which 
seem to have exhibited after my last “emerge world -uDN”.

At that time, I upgraded llvm/clang 3.9.1 to 5.0.1 and I remember I run into 
some blocking packages. After a bit of tinkering, the thing just worked. 
However, as soon the upgrade completed, I had the bright idea of upgrading the 
profile with eselect.

Then, the mystery. I might have run couple of times “emerge world -uDN” without 
encountering problems, but then at certain point emerge started complaining 
about the missing compiler. If nothing works, I can recover the last working 
prefix from time machine and try the upgrade once again.

Below, my current make.conf file. 

Askars-iMac:portage askarbektassov$ cat make.conf
# System compiler on Darwin Prefix is Clang, do not remove this
#CC=x86_64-apple-darwin15-clang
#CXX=x86_64-apple-darwin15-clang++
#BUILD_CC=x86_64-apple-darwin15-clang
#BUILD_CXX=x86_64-apple-darwin15-clang++

# As per grob...@gentoo.org suggestion on 27/02/2018
CC=${CHOST}-clang
CXX=${CHOST}-clang++
BUILD_CC=${CHOST}-clang
BUILD_CXX=${CHOST}-clang++

# Added by bootstrap-prefix.sh for x86_64-apple-darwin15
USE="unicode nls"
CFLAGS="${CFLAGS} -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j5"
CONFIG_SHELL="/Users/askarbektassov/Gentoo/bin/bash"

# This disables /usr-split, removing this will break
PREFIX_DISABLE_GEN_USR_LDSCRIPT=yes
Askars-iMac:portage askarbektassov$ 
--
Askar Bektassov (Аскар Бектасов)
Sent from tablet, please excuse my brevity and typos

> On 4 Mar 2018, at 21:34, Fabian Groffen <grob...@gentoo.org> wrote:
> 
>> On 04-03-2018 21:26:45 +0100, Askar Bektassov (Аскар Бектасов) wrote:
>> Hi Fabian,
>> 
>> Sorry for late reply. I changed make.conf as suggested, but still no luck.
>> 
>> I observe that in the $EPREFIX/usr/lib/llvm/5/bin folder I only have symlinks
>> to x86_64-apple-darwin15-clang* files. So, I assume that unless I change the
>> symlinks, I am bound to use x86_64-apple-darwin15-clang* compiler. As a side
>> note, I tried installing gcc-apple as well, but it fails during 
>> configuration,
>> complaining about ld.
> 
> On macOS, you MUST use clang.  If you don't use it, you're on your own.
> Many of the system headers can only be used with recent Clang.
> 
>> askarbektassov@Askars-iMac ~/Gentoo/usr/lib/llvm/5/bin $ emerge gcc-apple
> 
>> gcc-config > .gcc-config
>> 
>> x86_64-apple-darwin15-clang -march=native -O2 -pipe -Wall -Wextra
>> '-DEPREFIX="/Users/askarbektassov/Gentoo"' -Wl,-dead_strip_dylibs  wrapper.c 
>>  -o wrapper
>> 
>> chmod a+rx .gcc-config
>> 
>> wrapper.c:281:14: warning: unused parameter 'argc' [-Wunused-parameter]
>> 
>> int main(int argc, char *argv[])
>> 
>>              ^
>> 
>> 1 warning generated.
>> 
>> ld: failed to locate the real ld!
> 
> Did you, or did you not change something in your make.conf?  If so, what
> exactly did you change?  I suspect you changed something vital.
> 
> Fabian
> 
> -- 
> Fabian Groffen
> Gentoo on a different level

Reply via email to